Internet Outage
Incident Report for Holy Spirit School
Postmortem

Comcast experienced a momentary service disruption to customers in the immediate area. Services came online within ~30min. Monitored internet stability for the next 3 hours.

Posted Apr 24, 2022 - 15:26 PDT

Resolved
Comcast ISP service disruption
Posted Mar 24, 2022 - 11:45 PDT