Power Outage
Incident Report for Holy Spirit School
Resolved
Power restored.. Security systems needing intervention by 3rd party support.
Posted Mar 14, 2024 - 04:21 PDT
Investigating
Power lost to the facility.
Posted Mar 14, 2024 - 01:11 PDT
This incident affected: Campus Electrical Feed, Campus Network, and VOIP Phones.