Power Outage
Incident Report for Holy Spirit School
Resolved
This incident has been resolved. Power restored. Network and Security systems back online.
Posted Mar 09, 2024 - 14:38 PST
Update
We are continuing to investigate this issue. - Network and Security Systems offline
Posted Mar 09, 2024 - 13:30 PST
Investigating
Campus experienced utility power disruption
Posted Mar 09, 2024 - 13:18 PST
This incident affected: Campus Electrical Feed, Campus Network, and VOIP Phones.