School Speak site outage
Incident Report for Holy Spirit School
Resolved
This incident has been resolved.
Posted Jan 12, 2022 - 22:29 PST
Update
We are continuing to investigate this issue.
Posted Jan 12, 2022 - 12:24 PST
Investigating
School Speak reports slowness and inaccessibility when trying to reach their site.

School Speak admins are working on recovery. No reported ETOR at this time
Posted Jan 12, 2022 - 08:21 PST
This incident affected: HSS FACTS.